Miscellaneous Graphics Card Repair

Mostly Radeon R9s etc that I work on, but haven’t gotten around to.

Nvidia Cards

  • Nividia Tesla C2050 3GB (listed as ‘used, tested, working’ – won it pretty cheap, unusual card. Hoping a) works b) I can actually test it properly c) interesting buy – gets to windows, need to manually install drivers and test)
  • EVGA GTX 570 2.5Gb (Was very, very dusty when I got it, basically works under light load, will crash soon after heavy load e.g. Furmark crashes, Roblox OK – Would suspect either vram or gpu is faulty or faulty solder joint caused by overheating)

Radeon Cards

  • XFX HD7850 (FX-785A-ZDF4) (drivers don’t load, previously had patterned artefacts – reflow fixed artefacts – ideally needs memory chip replacement and it’s HDMI replaced)
  • Gigabyte Windforce R9 290X GV-R929XOC-4GD (pcb damage seemingly through someone’s poor workmanship, no voltage rails)
  • Gigabyte R9 290X GV-R929XOC-4GD (Card B) (listed as faulty, hoping to use this to help restore Gigabyte Windforce R9 290X GV-R929XOC-4GD – Missing or very low vcore, otherwise seems in much better condition than my other R9 290x)
  • SAPPHIRE RADEON R7 265 DUAL-X (stated as no power – has no power because there is a short on the 12v connector)
  • XFX Radeon 7950 3Gb (doesn’t post, need to check voltages)
  • Dataland R9 370 2Gb (missing vcore & vmem)
  • XFX HD 7950 (was very cheap, may be scrap, but I have another identical card XFX HD 7950 3Gb so could be useful dead or alive – damage at least to a mosfet and another chip on the back, memory resistance 1 ohm, should remove the damaged components to see if the short goes away, if not could well be spare parts)
  • XFX R9 280X 3GB (seller note ‘fans work, blank screen’ – this is true or rather blank screen after driver load – if memory-related, need to know which chip)
  • XFX HD 6950 2GB (stated as drivers load no output – this appears accurate, there is no picture, but as a second card it appears to be detected, but I think it actually crashes when it tries to use it’s drivers at all – guessing some kind of memory or gpu issue – perhaps worth trying a reflow of vram)
  • Sapphire Nitro R9 390 8Gb OC (works 5 – 10 mins then crashes to a blank screen, possibly when hot)
  • ASUS AMD RADEON R9 380 4GB STRIX (Has voltage rails, but not detected – needs new pads and logic chip to allow detection)